2011年12月8日木曜日

Google カスタム検索の設定で凡ミス


一般的なブログサービスには、ブログ内検索がついていることが多いようです。その場合には、コンテンツとかレイアウト設定をすれば、ブログ内の検索が反映されます。しかし、ブログ内のコメントも含めた検索ができることはあまりないようです。Bloggerはコメントも検索対象のようですが・・。

一般的なブログサービスで、コメントを含めたサイト内検索ができるようにするには、Googleカスタム検索が有効です。
以前にも設定したことがあったので、何も考えずに、
[検索エンジンに含めるサイト]にブログサイトURLを入力し、設置。

カスタム検索設置について書かれたブログやフォーラム等にしばらく待てば反映されると書かれていましたので、数時間待ってみることに。
(対象となるサイトは、このカスタム検索に関係なく、Googleの通常検索で、キーワードを入力して site:○○○.○○○.comと入力すると問題なく検索できているサイトです)
数時間待っても、反映されないので、翌日やってみることに。しかし、反映されず、ブログのtopページのみが検索されるのみです。
翌々日やってみても同じ結果です。

そういえば、昔、設置した時には、反映されるのに1週間くらいかかったなと、1週間後に検索してみましたが、全く同じ症状。検索されるときにはtopページのみ。それ以外は「結果はありません」。。

さすがに不安になり、Googleのサポートページを読んでみたり、いろいろ検索してみましたが、解決方法わからず。。

再度、初期設定からやり直してみようと、設定の見直しをしたところ・・・・

[検索エンジンに含めるサイト]のブログ名をhttp://から記入していました。このhttp://を外して、、設定し直してみたところ、通常のGoogle検索で条件検索をした結果と同じ結果が表示されるように。

うーむ。なんという凡ミス。。。


カスタム検索の設置コントロールパネルでは、[インデックス作成]登録画面で、
・サイトマップによるオンデマンド インデックス登録
http://www.mysite.com/sitemap.xml

・個別の URL によるオンデマンド インデックス登録
http://www.mysite.com/mypage.html

でいいようなんですが、
コントロールパネルの[サイト]登録画面で、
・追加したサイト、除外したサイトのURLを登録する
www.mysite.com

とするようです。

以前、別のサイトでカスタム検索を設置した時には、何も考えずにうまくいったのですが、
「Googleカスタム検索の設置ってどうすればいいの?」
と聞かれながら、設定していたら、このサイト登録時に、ついうっかり、http://をつけてしまったという凡ミス。(と、他人のせいにしてはいけませんね:笑)

カスタム検索エンジン ヘルプのURLパターンと使用法を読んでも、http://はつけていないといえばつけていないのですが・・。

URLの入力時には、http://をつけて入力する場合と、つけずに入力する場合があるということ。
ブログのコメント投稿時に、ホームページアドレスでhttp://をつけるかどうかも迷うことあるけど。


今回の場合、あれこれ弄り回さずに、1週間放置して、再度設定からやり直しただけだから、労力はほとんどかからなかったのですが、関係ありそうなところを設定変更し始めると、どつぼにはまることも。

なにはともあれ、ブログ内検索が有効になって、ほっとしました。


ヘルプのURLパターンと使用法をよく読むと、http://www.mysite.com/とhttp://をつけると、完全一致パターンの検索になり、topページのみが検索対象で、なんらかの検索がtopページで引っかかった時に、topページが表示されるというなのかもしれません)


2011年6月28日火曜日

iGoogleのナビゲーションバーが黒色に

昨日辺りから chromeを使って、iGoogleにアクセスすると、ナビゲーションバーが黒色に。


特にiGoogleの設定を変更したりはしていないのですが・・・。
何か仕様変更なのでしょうか。

確認してみたこと
  • iGoogleのテーマの変更をして元に戻してみたが駄目。
  • Firefoxでアクセスしてみると、いつもの見慣れたナビゲーションバー。
  • (“もっと見る”の要素がいつの間にか増えた?)
  • 別のアカウントでアクセスしても黒色バーになる。
  • 他のパソコンでアクセスすると、いつもの見慣れたナビゲーションバー。
ということは、chromeのなんらかの仕様変更で、設定によってはiGoogleのナビゲーションバーが黒色になってしまうのでしょうか?

chromeの設定画面を開いても変更できそうなところはないし・・・。

色が変わるだけのようなので、気にしなければいいのでしょうけど、なにせ黒色なので・・・。

“iGoogleのナビゲーションバーが黒色に”“iGoogleのナビゲーションバーが黒くなる”で Google 検索してみたけど、どうも見つからず・・・。

アンインストールして、インストールし直せば元に戻るのかもしれないけど、拡張機能とかも設定しなおさないといかんのだし・・・。


(追記)
black navigation bars  google でGoogle検索してみたら、この症状は結構出現している模様。
Google's Experimental Black Navigation Bar
を読むと、iGoogleだけではなく、YouTubeでもブラックなナビゲーションバーが表れているようだ。
(YouTubeアカウントを使っていないので確認していないが・・)

Googleのクッキーを削除すればいいのかな?

chromeのクッキーはどこにあるんだっけ?

設定→オプション→高度な設定→コンテンツの設定→Cookie→すべてのCookieとサイトデータ...

か。Googleのクッキーがいっぱいあってどれだろう?全部削除してみるか。。。


(追々記)
chromeのクッキーを全部削除してみたが、ブラックバーは消えず。。。


(追々々記)
あれっ、firefox でも black bar になっている。。。


(追々々々記)
firefox、opera、IEでもblack navigation barになっている。。。
別のパソコンでも。。。

ということは、なんらかの仕様変更、デザイン変更ということか。

オフラインでの利用云々はバーに何も表示されていないから、関係はなさそうな。

まあ、Googleを利用するなら予告無しの仕様変更は日常的なこととして受け入れないと。