2011年12月8日木曜日

Google カスタム検索の設定で凡ミス


一般的なブログサービスには、ブログ内検索がついていることが多いようです。その場合には、コンテンツとかレイアウト設定をすれば、ブログ内の検索が反映されます。しかし、ブログ内のコメントも含めた検索ができることはあまりないようです。Bloggerはコメントも検索対象のようですが・・。

一般的なブログサービスで、コメントを含めたサイト内検索ができるようにするには、Googleカスタム検索が有効です。
以前にも設定したことがあったので、何も考えずに、
[検索エンジンに含めるサイト]にブログサイトURLを入力し、設置。

カスタム検索設置について書かれたブログやフォーラム等にしばらく待てば反映されると書かれていましたので、数時間待ってみることに。
(対象となるサイトは、このカスタム検索に関係なく、Googleの通常検索で、キーワードを入力して site:○○○.○○○.comと入力すると問題なく検索できているサイトです)
数時間待っても、反映されないので、翌日やってみることに。しかし、反映されず、ブログのtopページのみが検索されるのみです。
翌々日やってみても同じ結果です。

そういえば、昔、設置した時には、反映されるのに1週間くらいかかったなと、1週間後に検索してみましたが、全く同じ症状。検索されるときにはtopページのみ。それ以外は「結果はありません」。。

さすがに不安になり、Googleのサポートページを読んでみたり、いろいろ検索してみましたが、解決方法わからず。。

再度、初期設定からやり直してみようと、設定の見直しをしたところ・・・・

[検索エンジンに含めるサイト]のブログ名をhttp://から記入していました。このhttp://を外して、、設定し直してみたところ、通常のGoogle検索で条件検索をした結果と同じ結果が表示されるように。

うーむ。なんという凡ミス。。。


カスタム検索の設置コントロールパネルでは、[インデックス作成]登録画面で、
・サイトマップによるオンデマンド インデックス登録
http://www.mysite.com/sitemap.xml

・個別の URL によるオンデマンド インデックス登録
http://www.mysite.com/mypage.html

でいいようなんですが、
コントロールパネルの[サイト]登録画面で、
・追加したサイト、除外したサイトのURLを登録する
www.mysite.com

とするようです。

以前、別のサイトでカスタム検索を設置した時には、何も考えずにうまくいったのですが、
「Googleカスタム検索の設置ってどうすればいいの?」
と聞かれながら、設定していたら、このサイト登録時に、ついうっかり、http://をつけてしまったという凡ミス。(と、他人のせいにしてはいけませんね:笑)

カスタム検索エンジン ヘルプのURLパターンと使用法を読んでも、http://はつけていないといえばつけていないのですが・・。

URLの入力時には、http://をつけて入力する場合と、つけずに入力する場合があるということ。
ブログのコメント投稿時に、ホームページアドレスでhttp://をつけるかどうかも迷うことあるけど。


今回の場合、あれこれ弄り回さずに、1週間放置して、再度設定からやり直しただけだから、労力はほとんどかからなかったのですが、関係ありそうなところを設定変更し始めると、どつぼにはまることも。

なにはともあれ、ブログ内検索が有効になって、ほっとしました。


ヘルプのURLパターンと使用法をよく読むと、http://www.mysite.com/とhttp://をつけると、完全一致パターンの検索になり、topページのみが検索対象で、なんらかの検索がtopページで引っかかった時に、topページが表示されるというなのかもしれません)


2011年6月28日火曜日

iGoogleのナビゲーションバーが黒色に

昨日辺りから chromeを使って、iGoogleにアクセスすると、ナビゲーションバーが黒色に。


特にiGoogleの設定を変更したりはしていないのですが・・・。
何か仕様変更なのでしょうか。

確認してみたこと
  • iGoogleのテーマの変更をして元に戻してみたが駄目。
  • Firefoxでアクセスしてみると、いつもの見慣れたナビゲーションバー。
  • (“もっと見る”の要素がいつの間にか増えた?)
  • 別のアカウントでアクセスしても黒色バーになる。
  • 他のパソコンでアクセスすると、いつもの見慣れたナビゲーションバー。
ということは、chromeのなんらかの仕様変更で、設定によってはiGoogleのナビゲーションバーが黒色になってしまうのでしょうか?

chromeの設定画面を開いても変更できそうなところはないし・・・。

色が変わるだけのようなので、気にしなければいいのでしょうけど、なにせ黒色なので・・・。

“iGoogleのナビゲーションバーが黒色に”“iGoogleのナビゲーションバーが黒くなる”で Google 検索してみたけど、どうも見つからず・・・。

アンインストールして、インストールし直せば元に戻るのかもしれないけど、拡張機能とかも設定しなおさないといかんのだし・・・。


(追記)
black navigation bars  google でGoogle検索してみたら、この症状は結構出現している模様。
Google's Experimental Black Navigation Bar
を読むと、iGoogleだけではなく、YouTubeでもブラックなナビゲーションバーが表れているようだ。
(YouTubeアカウントを使っていないので確認していないが・・)

Googleのクッキーを削除すればいいのかな?

chromeのクッキーはどこにあるんだっけ?

設定→オプション→高度な設定→コンテンツの設定→Cookie→すべてのCookieとサイトデータ...

か。Googleのクッキーがいっぱいあってどれだろう?全部削除してみるか。。。


(追々記)
chromeのクッキーを全部削除してみたが、ブラックバーは消えず。。。


(追々々記)
あれっ、firefox でも black bar になっている。。。


(追々々々記)
firefox、opera、IEでもblack navigation barになっている。。。
別のパソコンでも。。。

ということは、なんらかの仕様変更、デザイン変更ということか。

オフラインでの利用云々はバーに何も表示されていないから、関係はなさそうな。

まあ、Googleを利用するなら予告無しの仕様変更は日常的なこととして受け入れないと。

2009年9月19日土曜日

Googleカレンダーがちょっとご機嫌が悪いのはなぜ?

普段の予定をGoogleカレンダーに書いて、通知設定をしているのですが、ここ数日、この通知機能が少しご機嫌斜めです。

自分ひとりの予定設定で、時間変動が許されるものは、Gmailの通知。会議とか時間通りに動かなければならないものは、Gmail+モバイル通知に設定しています。

ここ数日、モバイル通知に設定していない予定も丁寧にというか、モバイル通知されてしまいます。

過去には、通知設定しているにも関わらず、通知されないということがありましたが・・・・。

たしか、以前に起きた時は、
  • カレンダーの一つ一つの予定を保存ボタンを押し直してみたが駄目。
  • 予定を消去して、再度、同じ内容の予定を作成(元の内容と同じもの)したら正常動作。
だったような記憶があります。繰り返し設定が思うように設定できず、毎回試行錯誤。

もう数日様子を見て、モバイル通知が続くようなら、削除→作成の繰り返しをしようかと考えていますが・・・・。


この現象がなぜおきるのかは原因不明。ここ数週間でカレンダー設定を変更した記憶はないので、向こう側のなんらかの変更が原因かと。

まあ、通知されないんじゃなくて、おせっかいなくらい通知してくれているんで、ちょっと我慢すればいいだけなんですけど。



(追記)
別のGoogleアカウントで作成したカレンダーの通知機能は問題なく、正常動作しています。

ということは、すべてのGoogleスケジュールでなんらかのトラブルが起きるというよりは、個別の設定とかによって変わってくるということでしょうか。

あるいは、繰り返し設定の場合、ある一定期間を過ぎて設定されているものについては、警告の意味も含めてモバイル通知するとか・・・。アカウントをとって、カレンダー設定はしたけど、そのまま放置して、現在は利用していない(だけどメール通知だけはされている)場合とか。

あっ、でも不要なモバイル通知が来ているアカウントは、ほぼ毎日、ブラウザアクセスしているほうか・・・。

2009年8月19日水曜日

Googleフォームの文字化けは修正済み?

GoogleフォームをIEで表示すると文字化けすると書きましたが、どうやら修正が終了した模様。本日、IEでアクセスしてみると、問題なく表示されました。

見逃しているのかもしれませんが、特にアナウンスされていないような・・・・。

2009年8月10日月曜日

GoogleChromeでsitesのhtml編集をしても動作するように

GoogleChrome で Google sites の html 編集をすると、フリーズしていたのですが、パソコンを買い換えたら問題なく処理できるようになりました。(Firefox では旧パソコンでも sites の html 編集をしてもフリーズはしませんでした)

タスクマネージャで確認すると、旧パソコンの時には、cpu 使用が一気に100%でそのままフリーズしてしまったのですが、新しくしてからは、html 編集画面で cpu 使用率はかなり上がりますが、短時間で下降してきます。

Chromeはスペックの低いパソコンでも一般的な動作は軽いのですが、sitesのhtml編集をする時などは、それなりのスペックは求められるのかもしれません。

ブラウザとしてではなくOSになってくると、その動作はどんな感じになってくるのでしょうかね?

パソコンを買い換えたら悩みが少し解消されました。

先月パソコンを買い換えました。windowsXPですが、今まで使っていたパソコンに比べると、そこそこにスペックが向上したのでだいぶ動作が軽くなりました。

パソコンは自動車とは違い、まだまだ機能向上が選択基準ですかね。6万円そこそこで、これだけ快適になるのなら、もっと早く買い換えればよかったかと。

データファイルを整理し、プログラムを必要最小限インストールしました。今回からMS-officeをインストールせずに、可能な限り、ネット対応、オープンソース対応にしてみることにしました。

ファイル数が大幅に減ったせいもあるのかもしれませんが、ノートンのシステムの完全スキャンを実施してもあっという間に終了するようになりました。アイドルタイムでも完全スキャンが終了しているようです。

Norton インターネットセキュリティ2009の動作環境として書かれている
  • CPU:300MHz以上のプロセッサ
  • メモリ:256MB以上のRAM
よりはもう少し余裕のあるスペックのほうが、十分なパフォーマンスが発揮できるということでしょうか?

2009年8月5日水曜日

Googleフォームはログインかログアウトかで見え方が異なる?

GoogleフォームをIEで表示すると文字化けすると書き、対策のようなことを書いたのですが、有効ではないことがわかりました。

対策のようなことは、フォーム所有者である自分がログインした時にのみ有効なようです。一般的なアクセスの場合には、フォーム所有者ではないのでIEで見ると???状態になるようです。

Firefoxでは文字化けはしませんが、フォーム所有者がログインした状態と、ログアウトした状態で見え方が異なるようです。

先の例ですと、Googleドキュメントの設定をEnglish(US)にして、ログインした状態では、書いたように Required で見えたのですが、ログアウトした状態で見ると、日本語で 必須 と表示されました。IEではログアウトすると、Requiredで見えたものが、ログアウトすると ?? と表示されました。

このGoogleフォームの文字化けの件は、Google側の作業を待つしかなさそうです。


また、問題は解決しなかったのですが、今回の件で学習したこと
  • Googleフォームは所有者がログインした状態で見るのと、ログアウトした状態で見るのでは、同じに見えるとは限らない。一度ログアウトして確認する必要がある。